Calculating pricing is slow or fails

Incident Report for Printavo

Resolved

Performance related to refreshing prices has been restored.
Posted Jun 24, 2025 - 17:33 CDT

Monitoring

A fix has been implemented and we will continue to monitor the issue
Posted Jun 24, 2025 - 16:49 CDT

Investigating

We are currently investigating issues where calculating prices can be slow or even fail completely.
Posted Jun 24, 2025 - 12:37 CDT
This incident affected: Product Catalog.