Emails not being received in Printavo
Incident Report for Printavo
Resolved
The issue has been resolved. Emails should now be properly received and will not be stuck. Any emails that were stuck have been pushed through.

If you are still not seeing any emails that were sent over please let us know by emailing support@printavo.com

Apologies for the inconvenience caused by this issue.
Posted Nov 15, 2023 - 21:42 CST
Update
We are continuing to investigate this issue.
Posted Nov 15, 2023 - 15:35 CST
Investigating
We are currently investigating an issue where email messages being sent into Printavo are not being delivered within a quote even when the customer is replying back to an existing thread.
Posted Nov 15, 2023 - 15:27 CST
This incident affected: Email.