Discover (Credit Card Company) Outage 02/06/23
Incident Report for Printavo
Resolved
Hello,

Discover has reported that the incident is resolved. Discover resolved an internal network issue to restore service. The Financial institution will continue to monitor the environment to ensure stability.

Best,
Printavo Team
Posted Feb 06, 2023 - 17:16 CST
Update
Discover is continuing to troubleshoot this issue but does not currently have an estimated time to resolution. We will continue to provide updates as they are given.
Posted Feb 06, 2023 - 16:09 CST
Update
We are working with our Financial institution to remain updated on this issue.
Posted Feb 06, 2023 - 14:29 CST
Identified
Hello,

Discover has alerted all Financial institutions that there is an issue at one of their data centers that could be causing failures for Discover transactions. If you or your customers are experiencing any issues paying with a Discover payment method, please be aware that this issue is being looked into by Discover. We will post any updates that we are made aware of.

Best,
Printavo Team
Posted Feb 06, 2023 - 14:29 CST
This incident affected: Payment Processors.