Printavo Slowness 05/01/23
Incident Report for Printavo
Resolved
After a brief period of interrmittent slowness yesterday we are no longer seeing any spikes in wait time or have received any reports from our users. We will continue to look into what caused this period of slowness and strive to mitigate these issues.

Apologies for the inconvenience to any affected users.
Posted May 02, 2023 - 10:10 CDT
Investigating
We have received reports that some users are experiencing slowness on the site since around noon today.
Our Engineering team is looking into the matter.
Updates will be provided as we know more.
Posted May 01, 2023 - 14:53 CDT
This incident affected: Website.