Printavo Slowness 05/10/23
Incident Report for Printavo
Resolved
We are not seeing any further spikes in slowness.

The root cause was identified as excessive requests from a customer integration that bypassed our rate-limiting layer. Our engineering team has implemented new rules to prevent this from happening in the future.

Thank you for your understanding and support.
Posted May 10, 2023 - 11:17 CDT
Monitoring
Good news! The website slowness issue has been resolved. We are now monitoring performance and investigating the cause.
Posted May 10, 2023 - 10:52 CDT
Identified
The Printavo website is currently experiencing a brief period of slowness. Our engineering team is actively investigating the issue to identify and resolve the underlying cause as quickly as possible. We apologize for any inconvenience this may cause and appreciate your patience.

Updates will be provided as we know more.
Posted May 10, 2023 - 10:34 CDT
This incident affected: Website.