Degraded Performance - 04/18/23
Incident Report for Printavo
Resolved
We are marking this incident as resolved as we are seeing no further issues and have not had any more reports of any persisting issues.

If you are still experiencing any issues, please reach out to us at support@printavo.com. Apologies for any inconvenience caused by this!

Best,
Posted Apr 18, 2023 - 13:27 CDT
Monitoring
We believe we have identified and fixed the issue, but we will be continuing to monitor to make sure we've got it nailed down
Posted Apr 18, 2023 - 11:50 CDT
Update
Some users are reporting parts of the site not working at all, we are continuing to investigate the issue.

Please reach out to us if you have any questions at support@printavo.com.

Best,
Posted Apr 18, 2023 - 11:29 CDT
Identified
The Printavo site is experiencing degraded performance due to a small release last night. If you are experiencing slow load times and occasional timeout errors on the site, please be advised we are looking into the issue and are working on a fix as quickly as possible.

Updates will be posted as we know more.

Best,
Posted Apr 18, 2023 - 11:04 CDT
This incident affected: Website.