EasyPost Outage

Incident Report for Printavo

Resolved

The issue with EasyPost has been resolved and we are fully operational.
Posted Jul 23, 2026 - 16:50 CDT

Monitoring

EasyPost has reported that they are operational again. We will be monitoring the status of their API.
Posted Jul 23, 2026 - 14:41 CDT

Identified

EasyPost is experiencing connectivity issues and there has been a disruption in features using the EasyPost API.
Posted Jul 23, 2026 - 13:45 CDT
This incident affected: EasyPost Address Verification, EasyPost FedEx, EasyPost UPS, EasyPost USPS, EasyPost Tracking, and EasyPost USPS Postage Purchases.