PowerSchedule drag-drop not working as expected

Incident Report for Printavo

Resolved

We have released fixes for the drop-drop and filtering issues in the PowerScheduler. Please refresh your browser to ensure you get the latest fixes.
Posted Jan 28, 2025 - 15:20 CST

Identified

The issue has been identified, along with an additional filtering issue, and a fix is being worked on.
Posted Jan 28, 2025 - 14:13 CST

Investigating

We are currently investigating an issue where drag and drop doesn't work correctly if you scroll down too far on the PowerSchedule page.
Posted Jan 28, 2025 - 13:24 CST
This incident affected: Website.