Upstream email provider experiencing service disruption
Incident Report for Printavo
Resolved
This incident has been resolved.
Posted Dec 04, 2023 - 16:00 CST
Update
At the moment things appear to be full operational again, though our engineering team is keeping an eye on the situation.
Posted Dec 04, 2023 - 15:59 CST
Update
At the moment the email queue is empty and we are monitoring the situation before declaring the outage over.
Posted Dec 04, 2023 - 15:40 CST
Investigating
This is similar to what happened this morning, our provider is once again experiencing delays delivering email messages.
Posted Dec 04, 2023 - 15:11 CST
This incident affected: Email.