Printavo Slowness/Timeout 05/15/23
Incident Report for Printavo
Resolved
We have not received any additional reports of slowness or timeout errors since 12:30pm CST. This incident has been marked as resolved. If you are experiencing any further issues, please let us know at support@printavo.com.

An in-depth post-mortem will be provided as soon as possible in order to address this incident and the previous incidents we've experienced over the last few weeks.
Posted May 15, 2023 - 12:45 CDT
Monitoring
The engineering team has addressed the issue and the slowness/timeout errors have subsided. We are actively monitoring for any more issues.

We are looking to provide an in-depth post-mortem in the next couple of days to address this, and previous outages/slowness that have occurred.

The Printavo Team and I sincerely apologize for any issues you have experienced around this and previous incidents.

Alex Worrall & The Printavo Team
Posted May 15, 2023 - 12:30 CDT
Investigating
The Printavo website is currently experiencing slow load times and occasional timeouts.

We sincerely apologize for the inconvenience and are looking into this issue.

Updates will be provided as we know more.
Posted May 15, 2023 - 11:04 CDT
This incident affected: Website.