Printavo Slowness 04/26/23
Incident Report for Printavo
Postmortem

Hello Printavo users!

I want to apologize for the repeated periods of slowness and outages that have occurred in the last seven days. We understand the inconvenience this has caused and want to assure you that we are doing everything in our power to prevent these incidents from happening again.

On 04/24/23, we reported in a post-mortem that the first two outages were caused by DDoS attacks. We have taken measures to strengthen our defenses against these attacks, working closely with our engineering team to monitor and prevent future attacks.

Today's slowness was caused by higher-than-usual request queue wait times that resulted in degraded performance for end-users. We are currently investigating the root cause of this issue and have taken steps to prevent this from happening again. Our team is actively working to optimize our systems to ensure that we can handle increased traffic during peak usage times.

We understand that these issues have caused a great deal of frustration, and we want to assure you that we are committed to resolving these issues as quickly as possible. We will continue to provide updates as we work to mitigate these issues, and we appreciate your patience and understanding.

Thank you for your continued patience during these issues.

Sincerely,

Alex Worrall & the Printavo Team

Posted Apr 26, 2023 - 12:07 CDT

Resolved
We have not received any more reports or seen any extended period of slowness in the last 30 minutes.
If you are experiencing any issues please let us know at support@printavo.com.

We will follow up with a post-mortem of this issue today. We sincerely apologize to any affected users.
Posted Apr 26, 2023 - 11:00 CDT
Monitoring
The site appears to be operating with normal load times currently. We are actively monitoring to ensure things are back to normal.
Posted Apr 26, 2023 - 10:32 CDT
Investigating
Parts of the Printavo site are experiencing intermittent periods of slowness when loading. Our engineering team is looking into this.

Updates will be provided as soon as we know more.
Posted Apr 26, 2023 - 10:10 CDT
This incident affected: Website.